Tag Archives: algorithms

Πληροφορική Γ’ ΓΕΛ: Υποπρογράμματα και πίνακες

Για τις ανάγκες του μαθήματος Πληροφορική (πρώην: “Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον”) της Γ’ τάξης Γενικού Λυκείου, μπορείτε να βρείτε στην ηλεκτρονική σχολική τάξη του μαθήματος παράδειγμα με υποπρογράμματα και πίνακες σε ΓΛΩΣΣΑ. Είναι διαθέσιμο εδώ σε μορφή PDF και εδώ σε … Continue reading

Posted in Δευτεροβάθμια εκπαίδευση | Tagged , , , , , , , | Leave a comment

Πληροφορική Γ’ ΓΕΛ: Έλεγχος συμμετρίας ως προς την κύρια διαγώνιο σε τετραγωνικό πίνακα

ΠΡΟΓΡΑΜΜΑ Έλεγχος_συμμετρίας_ως_προς_κύρια_διαγώνιο ΣΤΑΘΕΡΕΣ Ν = 4 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: i, j, Π[Ν,Ν] ΛΟΓΙΚΕΣ: συμμετρικός ΑΡΧΗ ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ Ν ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ Ν ΓΡΑΨΕ ‘Δώστε το στοιχείο Π[‘, i, ‘,’, j, ‘]’ ΔΙΑΒΑΣΕ Π[i,j] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ συμμετρικός … Continue reading

Posted in Δευτεροβάθμια εκπαίδευση | Tagged , , , , | Leave a comment

Υλοποίηση ουράς σε ΓΛΩΣΣΑ: νέα έκδοση για το σχολικό έτος 2019-2020

Για τις ανάγκες του μαθήματος Πληροφορική (πρώην: “Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον”) της Γ’ τάξης Γενικού Λυκείου, μπορείτε να βρείτε στην ηλεκτρονική σχολική τάξη του μαθήματος μια νέα υλοποίηση ουράς (με χρήση μονοδιάστατου πίνακα) σε ΓΛΩΣΣΑ. Έχει ξαναγραφεί ειδικά για το σχολικό έτος … Continue reading

Posted in Δευτεροβάθμια εκπαίδευση | Tagged , , , , | Leave a comment

Υλοποίηση στοίβας και ουράς σε ΓΛΩΣΣΑ

Για τις ανάγκες του μαθήματος Πληροφορική (πρώην: “Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον”) της Γ’ τάξης Γενικού Λυκείου, μπορείτε να βρείτε στην ηλεκτρονική σχολική τάξη του μαθήματος υλοποίηση στοίβας και υλοποίηση ουράς (με χρήση μονοδιάστατου πίνακα) σε ΓΛΩΣΣΑ. Η υλοποίηση της στοίβας είναι διαθέσιμη εδώ σε … Continue reading

Posted in Δευτεροβάθμια εκπαίδευση | Tagged , , , , , | Leave a comment

Υλοποίηση αλγορίθμου ταξινόμησης SelectionSort σε ΓΛΩΣΣΑ

Για τις ανάγκες του μαθήματος Πληροφορική (πρώην: “Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον”) της Γ’ τάξης Γενικού Λυκείου, μπορείτε να βρείτε στην ηλεκτρονική σχολική τάξη του μαθήματος μια υλοποίηση του αλγόριθμου ταξινόμησης SelectionSort σε ΓΛΩΣΣΑ. Το πρόγραμμα σε ΓΛΩΣΣΑ είναι διαθέσιμο εδώ σε μορφή PDF … Continue reading

Posted in Δευτεροβάθμια εκπαίδευση | Tagged , , , , | Leave a comment