Απλές Ασκήσεις

Κάτω από: Επιστήμη των Υπολογιστών | ΠΟΛΥΠΟΡΤΗ ΠΑΡΑΣΚΕΥΗ
Σάββατο, 21 Δεκέμβριος 2019 9:50 πμ |  Με ετικέτα |

A.Να σχεδιάσετε το διάγραμμα ροής του παρακάτω αλγορίθμου:

αλγόριθμος A

Χ←10

διάβασε Υ

αν Χ>Υ τότε

γράψε Χ-1

αλλιώς_αν Χ<Υ τότε

γράψε Χ-2

αλλιώς

γράψε Χ-3

τέλος_αν

τέλος Β2

B. Να γίνει το διάγραμμα ροής του παρακάτω αλγορίθμου.

Αλγόριθμος A
  α ← 3
  β ← 1
  γ ← 5
  Αν (α mod 2 = 1) ή (β >= 2) τότε
    γ ← γ + 2
    α ← α ^ 3
 Αλλιώς
      β ← 4 * β
Τέλος_αν
 α ← α mod β
 β ← β mod γ
 γ ← γ mod α

εμφάνισε α, β



Δεν υπάρχουν σχόλια

Χωρίς σχόλια ακόμα.

RSS κανάλι για τα σχόλια του άρθρου.