ΑΣΚΗΣΕΙΣ ΓΕΝΙΚΕΣ ΣΤΙΣ ΕΠΑΝΑΛΗΨΕΙΣ

ΑΣΚΗΣΗ Γ1 *
Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να διαβάζει αριθμούς μέχρι να δοθεί ο αριθμός 0 και να υπολογίζει το πλήθος των θετικών, το πλήθος των αρνητικών και το συνολικό πλήθος και να τα εμφανίζει.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ1
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : Χ
ΑΚΕΡΑΙΕΣ :  ΠΛ_Θ, ΠΛ_Α, ΠΛ
ΑΡΧΗ
ΠΛ <- 0
ΠΛ_Α <- 0
ΠΛ_Θ <- 0
ΓΡΑΨΕ ‘ΔΩΣΕ ΑΡΙΘΜΟ (0 ΓΙΑ ΤΕΡΜΑΤΙΣΜΟ)’
ΔΙΑΒΑΣΕ Χ
ΟΣΟ Χ<>0 ΕΠΑΝΑΛΑΒΕ
ΠΛ <- ΠΛ + 1
ΑΝ Χ>0 ΤΟΤΕ
ΠΛ_Θ <- ΠΛ_Θ +1
ΑΛΛΙΩΣ
ΠΛ_Α <- ΠΛ_Α +1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΠΛ_Θ, ΠΛ_Α, ΠΛ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ2 *
Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να διαβάζει τους μέσους όρους των βαθμών μαθητών μέχρι να δοθεί βαθμός αρνητικός. Να υπολογίζει και να εμφανίζει τον συνολικό μέσο όρο και το πλήθος των μαθητών. Σε περίπτωση που δε δοθεί κανένας βαθμός να εμφανίζεται αντίστοιχο μήνυμα.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ2
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : ΜΟ, ΣΜΟ, ΑΜΟ                                              !ΜΕΣΟΣ ΟΡΟΣ, ΣΥΝΟΛΙΚΟΣ ΜΕΣΟΣ ΟΡΟΣ, ΑΘΡΟΙΣΜΑ ΜΕΣΩΝ ΟΡΩΝ
ΑΚΕΡΑΙΕΣ :  ΠΛ                                                                                     !ΠΛΗΘΟΣ ΜΑΘΗΤΩΝ
ΑΡΧΗ
ΠΛ <- 0
ΑΜΟ <- 0
ΔΙΑΒΑΣΕ ΜΟ
ΟΣΟ ΜΟ>=0 ΕΠΑΝΑΛΑΒΕ
ΑΜΟ <- ΑΜΟ + ΜΟ
ΠΛ <- ΠΛ +1
    ΔΙΑΒΑΣΕ ΜΟ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΠΛ>0 ΤΟΤΕ
ΣΜΟ <- ΑΜΟ / ΠΛ
ΓΡΑΨΕ ‘Ο ΣΥΝΟΛΙΚΟΣ ΜΕΣΟΣ ΟΡΟΣ ΒΑΘΜΩΝ ΕΙΝΑΙ : ‘, ΣΜΟ
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘ΔΕΝ ΕΔΩΣΕΣ ΚΑΝΕΝΑ ΒΑΘΜΟ’
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ3 *
Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να βρίσκει και να εμφανίζει το γινόμενο αριθμών μέχρι να δοθεί από το χρήστη η είσοδος ΤΕΛΟΣ . Αν δεν δοθεί κανένας αριθμός τότε να εμφανίζει ως γινόμενο τον αριθμό 1.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ3
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : ΓΙΝ
ΧΑΡΑΚΤΗΡΕΣ : ΕΙΣ
ΑΡΧΗ
ΓΙΝ <- 1
ΔΙΑΒΑΣΕ ΕΙΣ
ΟΣΟ ΕΙΣ <> ‘ΤΕΛΟΣ’ ΕΠΑΝΑΛΑΒΕ
ΔΙΑΒΑΣΕ ΑΡΙΘΜΟ
ΓΙΝ <- ΓΙΝ * ΑΡΙΘΜΟ
    ΔΙΑΒΑΣΕ ΕΙΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΓΙΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ4 ***
Μια δημοτική επιχείρηση ύδρευσης ακολουθεί την παρακάτω πολιτική χρέωσης προς τους δημότες:
α) Πάγιο για κάθε λογαριασμό 20 ευρώ,
β) Για κατανάλωση μέχρι και 20 κυβικά μέτρα νερού χρέωση 1,5 ευρώ το κάθε κυβικό
γ) για κυβικά πάνω από 20 και μέχρι και 50, χρέωση 2,7 ευρώ το κυβικό
δ) για κάθε κυβικό πάνω από 50 χρέωση 5 ευρώ.
– Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να διαβάζει το όνομα και την κατανάλωση κάθε δημότη μέχρι να γίνει εισαγωγή αρνητικής κατανάλωσης νερού.
– Να υπολογίζει το συνολικό ποσό που χρωστά κάθε δημότης και να το εμφανίζει μετά από το Ονοματεπώνυμό του.
– Να υπολογίζει και να εμφανίζει τα συνολικά έσοδα της δημοτικής εταιρείας ύδρευσης.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ4
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : ΚΑΤΑΝΑΛΩΣΗ, ΧΡΕΩΣΗ, ΚΕΡΔΗ
ΧΑΡΑΚΤΗΡΕΣ :  ΔΗΜΟΤΗΣ
ΑΡΧΗ
ΕΣΟΔΑ <- 0
ΔΙΑΒΑΣΕ ΚΑΤΑΝΑΛΩΣΗ, ΔΗΜΟΤΗΣ
ΟΣΟ ΚΑΤΑΝΑΛΩΣΗ >=0 ΕΠΑΝΑΛΑΒΕ
ΑΝ ΚΑΤΑΝΑΛΩΣΗ <= 20 ΤΟΤΕ
ΧΡΕΩΣΗ <-ΚΑΤΑΝΑΛΩΣΗ * 1.5
ΑΛΛΙΩΣ_ΑΝ ΚΑΤΑΝΑΛΩΣΗ <=50 ΤΟΤΕ
ΧΡΕΩΣΗ <- 20*1.5 + (ΧΡΕΩΣΗ – 20)*2.7
ΑΛΛΙΩΣ
ΧΡΕΩΣΗ <- 20*1.5 + 30*2.5 + (ΧΡΕΩΣΗ – 50)*5
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ΔΗΜΟΤΗΣ, ΧΡΕΩΣΗ
ΚΕΡΔΗ <- ΚΕΡΔΗ + ΧΡΕΩΣΗ
ΔΙΑΒΑΣΕ ΚΑΤΑΝΑΛΩΣΗ, ΔΗΜΟΤΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ5 **
Να γράψετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να διαβάζει αριθμούς μέχρι το άθροισμα τους να γίνει μεγαλύτερο ή ίσο του 10000. Στο τέλος να εμφανίζει το γινόμενο και το πλήθος των αριθμών που διαβάστηκαν καθώς επίσης το ποσοστό και το πλήθος των θετικών και αρνητικών αριθμών που δόθηκαν.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ5
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : Χ, ΑΘΡ, ΓΙΝ, ΠΘ, ΠΑ
ΑΚΕΡΑΙΕΣ : ΠΛ, Θ, Α
ΑΡΧΗ
ΠΛ <- 0
ΑΘΡ <- 0
ΓΙΝ <- 1
Θ <- 0
Α <- 0

ΟΣΟ ΑΘΡ<10000 ΕΠΑΝΑΛΑΒΕ
ΔΙΑΒΑΣΕ Χ
ΑΘΡ <- ΑΘΡ + Χ
ΠΛ <- ΠΛ + 1
ΓΙΝ <- ΓΙΝ * Χ
ΑΝ Χ>0 ΤΟΤΕ
Θ <- Θ +1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Α<- ΠΛ – Θ
ΓΡΑΨΕ ΓΙΝ, ΠΛ
ΠΘ <- Θ*100/ΠΛ
ΠΑ <- Α*100/ΠΛ    !Ή ΠΑ <- 100 -ΠΘ
ΓΡΑΨΕ Θ, ΠΘ
ΓΡΑΨΕ Α, ΠΑ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ6 ***
Ένα φέρι-μποτ της γραμμής Κεφαλλονιά – Λευκάδα έχει χωρητικότητα 100 θέσεων. Ένα αυτοκίνητο καλύπτει 1 θέση και κόστος εισιτηρίου 50 ευρώ, ένα φορτηγό 3 θέσεις και εισιτήριο 100 ευρώ  και οι μηχανές καλύπτουν 0.5 θέσεις με εισιτήριο 15 ευρώ. Να γράψετε πρόγραμμα το οποίο να δέχεται τον τύπο τροχοφόρου προς επιβίβαση και να επιτρέπει την είσοδό του στο φέρι αρκεί η συνολική χωρητικότητα να μην ξεπερνά το 100. Επίσης να υπολογίζει και να εμφανίζει τα έσοδα της εταιρείας καθώς και το πλήθος των τροχοφόρων που ανέβηκαν στο πλοίο.
Το φέρι δεν θα αναχωρεί για τον προορισμό του αν δεν γεμίσει πλήρως (και τις 100 θέσεις του). Να γίνεται έλεγχος ορθότητας εισόδου.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ6
ΜΕΤΑΒΛΗΤΕΣ
ΧΑΡΑΚΤΗΡΕΣ: ΤΥΠΟΣ
ΑΚΕΡΑΙΕΣ : ΣΥΝ_ΧΩΡ, ΚΕΡΔΗ, ΠΛ
ΑΡΧΗ
ΠΛ <- 0
ΚΕΡΔΗ <- 0
ΣΥΝ_ΧΩΡ <- 0
ΟΣΟ ΣΥΝ_ΧΩΡ < 100 ΕΠΑΝΑΛΑΒΕ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ ΤΥΠΟΣ
ΜΕΧΡΙΣ_ΟΤΟΥ ΤΥΠΟΣ=’Μ’ Ή ΤΥΠΟΣ=’Α’ Ή ΤΥΠΟΣ=’Φ’

ΑΝ ΤΥΠΟΣ = ‘Μ’ ΚΑΙ (100 – ΣΥΝ_ΧΩΡ>= 0.5) ΤΟΤΕ
ΠΛ <- ΠΛ +1
ΣΥΝ_ΧΩΡ <- ΣΥΝ_ΧΩΡ + 0.5
ΚΕΡΔΗ <- ΚΕΡΔΗ + 15
ΑΛΛΙΩΣ_ΑΝ ΤΥΠΟΣ = ‘Α΄ΚΑΙ (100 – ΣΥΝ_ΧΩΡ >= 1) ΤΟΤΕ
ΠΛ <- ΠΛ +1
ΣΥΝ_ΧΩΡ <- ΣΥΝ_ΧΩΡ +1
ΚΕΡΔΗ <- ΚΕΡΔΗ + 50
ΑΛΛΙΩΣ_ΑΝ 100-ΣΥΝ_ΧΩΡ>=3 ΤΟΤΕ
ΠΛ <- ΠΛ +1
ΣΥΝ_ΧΩΡ <- ΣΥΝ_ΧΩΡ +3
ΚΕΡΔΗ <- ΚΕΡΔΗ + 100
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΚΕΡΔΗ, ΠΛ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ7 ***
Ένα τμήμα έχει 25 μαθητές. Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να διαβάζει τους βαθμούς τους στις εξετάσεις στα Μαθηματικά  με έλεγχο ορθότητας κατά την εισαγωγή (αποδεκτές τιμές 0 – 200). Οι βαθμοί είναι ακέραιοι με ελάχιστη δυνατή βαθμολογία το 1 και μέγιστη το 200. Η μηδενική βαθμολογία σημαίνει ότι ο μαθητής δεν προσήλθε στις εξετάσεις.
Να υπολογιστεί και να εμφανιστεί το πλήθος των μαθητών που προσήλθαν στις εξετάσεις και ο μέσος όρος των βαθμών τους.
Να υπολογιστεί και να εμφανιστεί το ποσοστό των μαθητών που πέρασαν την βάση (β>100).
Το πρόγραμμα να εμφανίζει κατάλληλο μήνυμα σε περίπτωση που δεν μπορεί να υπολογίσει το ΜΟ των βαθμών.
Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ7
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : ΠΟΣ_Π_Β, ΜΟ
ΑΚΕΡΑΙΕΣ : ΠΛ, Π_Β, Β, ΑΘΡ_Β, ι
ΑΡΧΗ
ΠΛ<-0
ΑΘΡ_Β<-0
Π_Β<-0

ΓΙΑ ι ΑΠΟ ΜΕΧΡΙ 25
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
ΔΙΑΒΑΣΕ Β
ΜΕΧΡΙΣ_ΟΤΟΥ Β>=0 ΚΑΙ Β<=200
ΑΝ Β<>0 ΤΟΤΕ
ΠΛ<-ΠΛ+1
ΑΘΡ_Β<-ΑΘΡ_Β+Β
ΑΝ Β>100 ΤΟΤΕ
Π_Β<-Π_Β+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΡΑΨΕ ΠΛ
ΑΝ ΠΛ<>0 ΤΟΤΕ
ΜΟ<-ΑΘΡ_Β/ΠΛ
ΓΡΑΨΕ ΜΟ
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘ΠΛΗΘΟΣ ΜΑΘΗΤΩΝ Ο. ΥΠΟΛΟΓΙΣΜΟΣ ΜΟ ΑΔΥΝΑΤΟΣ’
ΤΕΛΟΣ_ΑΝ 
ΠΟΣ_Π_Β<-(Π_Β/ΠΛ)*100
ΓΡΑΨΕ ΠΟΣ_Α_Β
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


τιμηΑΣΚΗΣΗ Γ8 ***
Μια οικογένεια πηγαίνει σε ένα σούπερ μάρκετ για τα ψώνια της εβδομάδας έχοντας 100 €. Να γράψετε πρόγραμμα το οποίο να υπολογίζει και να εμφανίζει :
– το πλήθος των προϊόντων που αγόρασαν
– το πιο φθηνό προϊόν
– το πιο ακριβό προϊόν
Το πρόγραμμα να τερματίζει μόνο αν ξοδευτούν και τα 100 €.
Έλεγχος ορθότητας δεν απαιτείται.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ8
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : ΤΙΜΗ, ΜΙΝ, ΜΑΧ, ΑΘΡ
ΑΚΕΡΑΙΕΣ : ΠΛ
ΑΡΧΗ
ΑΘΡ<-0
ΠΛ<-0
ΔΙΑΒΑΣΕ ΤΙΜΗ
ΜΙΝ<-ΤΙΜΗ
ΜΑΧ<-ΤΙΜΗ
ΟΣΟ ΑΘΡ+ΤΙΜΗ<=100 ΕΠΑΝΑΛΑΒΕ
ΠΛ<-ΠΛ+1
ΑΘΡ<-ΑΘΡ+ΤΙΜΗ
ΑΝ ΤΙΜΗ>ΜΑΧ ΤΟΤΕ
ΜΑΧ<-ΤΙΜΗ
ΑΛΛΙΩΣ_ΑΝ ΤΙΜΗ<ΜΙΝ ΤΟΤΕ
ΜΙΝ<-ΤΙΜΗ
ΤΕΛΟΣ_ΑΝ
ΔΙΑΒΑΣΕ 
ΤΙΜΗ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ΠΛ, ΜΙΝ, ΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ9***
Ένα ίντερνετ καφέ ακολουθεί τις εξής χρεώσεις: Για τις πρώτες 2 ώρες χρεώνει 0.05 € ανά λεπτό. Για τις επόμενες 3 ώρες χρεώνει 0.04 € ανά λεπτό. Τέλος για όσο χρόνο παραπάνω των 5 ωρών χρεώνει 0.02€ το λεπτό.
Να γράψετε πρόγραμμα το οποίο να υπολογίζει και να εμφανίζει το ποσό που θα χρεώσει ο ιδιοκτήτης σε κάθε ένα από τους 54 πελάτες που χρησιμιποίησαν το ίντερνετ, με είσοδο τα λεπτά χρήσης του κάθε πελάτη. Επίσης να βρείτε τα συνολικά μικτά έσοδα του μαγαζιού και να τα εμφανίσετε χρησιμοποιώντας το μήνυμα ‘ΣΥΝΟΛΙΚΑ ΕΣΟΔΑ’.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ9
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ : ΧΡ, ΑΘΡ
ΑΚΕΡΑΙΕΣ : Λ, Ι
ΑΡΧΗ
ΑΘΡ<-0
ΓΙΑ Ι ΑΠΟ ΜΕΧΡΙ 54
ΔΙΑΒΑΣΕ Λ
ΑΝ Λ<=120 ΤΟΤΕ
ΧΡ<-Λ*0.05
ΑΛΛΙΩΣ_ΑΝ Λ<=300 ΤΟΤΕ
ΧΡ<-120*0.05 + (Λ-120)*0.04
ΑΛΛΙΩΣ
ΧΡ<-120*0.05 + 180*0.04 +(Λ-300)*0.02
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ΧΡ
ΑΘΡ<-ΑΘΡ+ΧΡ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΓΡΑΨΕ ‘ΣΥΝΟΛΙΚΑ ΕΣΟΔΑ ‘,ΑΘΡ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ10*** ΝΕΑ ΑΣΚΗΣΗ
Μια εταιρεία ασφάλισης οχημάτων χρεώνει ανά εξάμηνο κάθε κάτοχο, σύμφωνα με τους παρακάτω πίνακες και με βάση τον τύπο( Α=αυτοκίκητο, Μ=μοτοσυκλέτα και Φ=φορτηγό) και τον κυβισμό.

ΑΥΤΟΚΙΝΗΤΟ
ΚΥΒΙΣΜΟΣ          ΚΟΣΤΟΣ ΑΝΑ ΚΥΒΙΚΟ
[1 – 1000]                                 0,1€
(1000-1500]                          0,2€
(1500-2000]                          0,3€
ΠΑΝΩ ΑΠΟ 2000               0,4€

ΜΟΤΟΣΥΚΛΕΤΑ
ΚΥΒΙΣΜΟΣ          ΚΟΣΤΟΣ ΑΝΑ ΚΥΒΙΚΟ
[1 – 100]                                 0,01€
(100-250]                             0,05€
(250-1000]                          0,1€
ΠΑΝΩ ΑΠΟ 1000            0,2€

ΦΟΡΤΗΓΟ
ΚΥΒΙΣΜΟΣ          ΚΟΣΤΟΣ ΑΝΑ ΚΥΒΙΚΟ
[1 – 2000]                                 0,4€
(2000-2500]                          0,5€
(2500-3000]                          0,7€
ΠΑΝΩ ΑΠΟ 3000               0,9€

Να φτιαχτεί πρόγραμμα σε γλώσσα το οποίο όσο εισάγεται κάποιος θετικός αριθμός για τον κυβισμό να :
1) Να διαβάζει τον τύπο του οχήματος, τον κυβισμό και εάν επιθυμεί ετήσιο συμβόλαιο. Αν θέλει ετήσιο συμβόλαιο να εισάγει ΝΑΙ στην ερώτηση «Επιθυμείτε ετήσιο συμβόλαιο;», αλλιώς να θεωρείτε ότι επιθυμεί εξαμηνιαίο συμβόλαιο. Στην περίπτωση που το συμβόλαιο είναι ετήσιο, να δίνεται έκπτωση 5% στον ασφαλισμένο. Ο τύπος οχήματος έχει αποδεκτές τιμές μόνο τις Α, Μ, Φ για τους τύπους που αναφέρθηκαν στην αρχή αλλιώς το πρόγραμμα να ξαναζητά τον τύπο μετά το μήνυμα «Παρακαλώ οι αποδεκτές τιμές για τον τύπο οχήματος είναι οι: Α, Μ, Τ!»
2)Να υπολογίζει και να εμφανίζει το τελικό κόστος ασφάλισης μετά την προσθήκη και του ΦΠΑ(24%).
Να ελέγχεται η εκυρότητα εισόδου για τον τύπο οχήματος αλλά και για την ετήσια ασφάλιση. Το κόστος ασφάλισης υπολογίζεται κλιμακωτά.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ10
ΜΕΤΑΒΛΗΤΕΣ
ΧΑΡΑΚΤΗΡΕΣ: τυπος, ετησια
ΑΚΕΡΑΙΕΣ : κυβισμος
ΑΡΧΗ
ΔΙΑΒΑΣΕ κυβισμός
ΟΣΟ κυβισμός>0 ΕΠΑΝΑΛΑΒΕ
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ !έλεγχος ορθότητας για τύπο
ΓΡΑΨΕ ‘Παρακαλώ οι αποδεκτές τιμές για τον τύπο οχήματος είναι οι: Α, Μ, Τ!’
ΔΙΑΒΑΣΕ τυπος
ΜΕΧΡΙΣ_ΟΤΟΥ τυπος=’Α’ Ή τυπος=’Μ’ Ή τυπος=’Φ’

ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ !έλεγχος ορθότητας για ετήσιο συμβόλαιο
ΓΡΑΨΕ ‘Επιθυμείτε ετήσιο συμβόλαιο;’
ΔΙΑΒΑΣΕ ετησια
ΜΕΧΡΙΣ_ΟΤΟΥ ετησια=’ΝΑΙ’ Ή ετησια=’ΟΧΙ’

ΑΝ τυπος=’Α’ ΤΟΤΕ !ΑΥΤΟΚΙΝΗΤΟ
ΑΝ κυβισμος<=1000 ΤΟΤΕ
ΚΟΣΤΟΣ<- κυβισμος*0.1
ΑΛΛΙΩΣ_ΑΝ κυβισμος <=1500 ΤΟΤΕ
ΚΟΣΤΟΣ<- 1000*0.1+(κυβισμος-1000)*0.2
​    ΑΛΛΙΩΣ_ΑΝ κυβισμος <=2000 ΤΟΤΕ
ΚΟΣΤΟΣ<- 1000*0.1+500*0.2+(κυβισμος-1500)*0.3
ΑΛΛΙΩΣ
ΚΟΣΤΟΣ<- 1000*0.1+500*0.2+500*0.3+(κυβισμος-2000)*0.4
ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ_ΑΝ τυπος=’Μ’ ΤΟΤΕ !ΜΟΤΟΣΥΚΛΕΤΑ
ΑΝ κυβισμος<= …..

ΤΕΛΟΣ_ΑΝ
ΑΛΛΙΩΣ !ΦΟΡΤΗΓΟ
ΑΝ κυβισμος<=…..
…..
ΤΕΛΟΣ_ΑΜ
ΤΕΛΟΣ_ΑΝ

ΑΝ ετησια=’ΝΑΙ’ ΤΟΤΕ
ΚΟΣΤΟΣ<-(ΚΟΣΤΟΣ*2)-0.05*ΚΟΣΤΟΣ
ΤΕΛΟΣ_ΑΝ
ΓΡΑΨΕ ΚΟΣΤΟΣ

​ΔΙΑΒΑΣΕ κυβισμος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ11 *** (επαλήθευση γινομένου (ύλη -δημοτικού)) ​ΝΕΑ ΑΣΚΗΣΗ
Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να διαβάζει 2 αριθμούς, έναν τριψήφιο Α και έναν μονοψήφιο Β καθώς και έναν τρίτο αριθμό ΠΙΘ_ΓΙΝ, ο οποίος θα είναι το προς επαλήθευση γινόμενο των δύο πρώτων αριθμών. Στόχος του προγράμματος είναι να γίνεται η επαλήθευση του αποτελέσματος με την παρακάτω διαδικασία.
α) Προσθέτουμε τις εκατοντάδες με τις δεκάδες και τις μονάδες του πρώτου αριθμού Α. Αν το άθροισμα είναι διψήφιος τότε προσθέτουμε τις δεκάδες με τις δεκάδες του τελευταίου και ο μονοψήφιος που προκύπτει εκχωρείται στην μεταβλητή Χ1.
β) Στην μεταβλητή Χ2 εκχωρείται ο αριθμός Β.
γ) Στην μεταβλητή Χ3 εκχωρείται ο αριθμός που προκύπτει με διαδικασία παρόμοια του α βήματος, μέχρι να έχουμε έναν μονοψήφιο αριθμό.
δ) Στην μεταβλητή Χ4 εκχωρείται μονοψήφιος αριθμός που προκύπτει από το γινόμενο Χ1*Χ2. Αν προκύψει διψήφιος τότε προσθέτουμε τις δεκάδες και τις μονάδες του και το αποτέλεσμα το εκχωρούμε στην Χ4.
Οι μεταβλητές Χ1, Χ2, Χ3, Χ4 είναι μονοψήφιοι ακέραιοι.
Το πιθανό γινόμενο είναι σωστό μόνο αν Χ3=Χ4.
Η διαδικασία να γίνεται για 10 γινόμενα.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ11
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ :  Α, Β, ΠΙΘ_ΓΙΝ, Χ1, Χ2, Χ3, Χ4, Υ1, Y2, ΧΔ, ΧΜ, ΧΙΛ, Ε, Δ, Μ​
ΑΡΧΗ
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
ΔΙΑΒΑΣΕ Α, Β, ΠΙΘ_ΓΙΝ
Χ2<-Β !ΥΠΟΛΟΓΙΣΜΟΣ Χ2
!ΥΠΟΛΟΓΙΣΜΟΣ Χ1
Ε<-Α DIV 100
Y1<-A MOD 100
Δ<-Y1 DIV 10
M<-Y1 MOD 10
X1<-E+Δ+Μ
ΑΝ Χ1>9 ΤΟΤΕ
ΧΔ<-Χ1 DIV 10
XΜ<- MOD 10
X1<-ΧΔ+ΧΜ
ΤΕΛΟΣ_ΑΝ
!Χ3 ΑΘΡΟΙΣΜΑ ΨΗΦΙΩΝ ΠΙΘ_ΓΙΝ ΜΕΧΡΙ ΝΑ ΚΑΤΑΛΗΞΟΥΜΕ ΣΕ ΜΟΝΟΨΗΦΙΟ
ΧΙΛ<-ΠΙΘ_ΓΙΝ DIV 1000
Y1<-ΠΙΘ_ΓΙΝ MOD 1000
E<-Y1 DIV 100
Y2<-Y1 MOD 100
Δ<-Y2 DIV 10
M<- Y2 MOD 10
X3<-ΧΙΛ+Ε+Δ+Μ
ΑΝ Χ3>9 ΤΟΤΕ
Χ1<-Χ3 DIV 10
X2<-X3 MOD 10
X3<-X1+X2
ΤΕΛΟΣ_ΑΝ
Χ4<-Χ1*Χ2 !ΑΡΙΘΜΟΣ Χ4
!ΕΠΑΛΗΘΕΥΣΗ ΓΙΝΟΜΕΝΟΥ
ΑΝ Χ3=Χ4 ΤΟΤΕ
ΓΡΑΨΕ  ‘ΤΟ ΓΙΝΟΜΕΝΟ ΕΠΑΛΗΘΕΥΤΗΚΕ!’
ΑΛΛΙΩΣ
ΓΡΑΨΕ ‘ΤΟ ΓΙΝΟΜΕΝΟ ΕΙΝΑΙ ΛΑΘΟΣ’
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΑΣΚΗΣΗ Γ12 *** (εύρεση πρώτων αριθμών) ΝΕΑ ΑΣΚΗΣΗ
Να φτιάξετε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο να υπολογίζει και να εμφανίζει όλους τους ΠΡΩΤΟΥΣ αριθμούς από το 2 μέχρι και τον ακέραιο Χ, ο οποίος εισάγεται από τον χρήστη. Πρώτοι είναι οι αριθμοί που διαιρούνται μόνο με τον εαυτό τους και το 1.

Απάντηση
ΠΡΟΓΡΑΜΜΑ Γ12
ΜΕΤΑΒΛΗΤΕΣ
ΑΚΕΡΑΙΕΣ :  Χ,Τ,Μ,ΥΠΟΛΟΙΠΟ
ΑΡΧΗ
ΔΙΑΒΑΣΕ Χ
Τ<-2    !ΤΡΕΧΩΝ ΑΡΙΘΜΟΣ ΠΟΥ ΕΛΕΓΧΟΥΜΕ ΑΝ ΕΙΝΑΙ ΠΡΩΤΟΣ
ΟΣΟ Τ<=Χ ΕΠΑΝΑΛΑΒΕ
ΠΛ_Δ<-0   !ΠΛΗΘΟΣ ΔΙΑΙΡΕΤΩΝ ΠΟΥ ΔΙΑΙΡΟΥΝ ΑΚΡΙΒΩΣ ΤΟΝ Χ
ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ Τ !ΜΕΤΡΗΤΗΣ ΑΠΟ ΤΟ 1 ΜΕΧΡΙ ΤΟΝ ΤΡΕΧΟΝΤΑ ΑΡΙΘΜΟ
ΥΠΟΛΟΙΠΟ<-Τ MOD Μ  !ΕΛΕΓΧΟΣ ΑΝ Ο Τ ΔΙΑΙΡΕΙΤΑΙ ΑΚΡΙΒΩΣ
ΑΝ ΥΠΟΛΟΙΠΟ=0 ΤΟΤΕ !Ο
ΠΛ_Δ<-ΠΛ_Δ+1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ ΠΛ_Δ=2 ΤΟΤΕ   !ΔΙΑΙΡΕΙΤΑΙ ΜΕ ΤΟ 1 ΚΑΙ ΤΟΝ ΕΥΑΤΟ ΤΟΥ
ΓΡΑΨΕ ‘Ο ΑΡΙΘΜΟΣ’, Τ ,’ ΕΙΝΑΙ ΠΡΩΤΟΣ ΑΡΙΘΜΟΣ!’
ΤΕΛΟΣ_ΑΝ
Τ<-Τ+1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Ο ΒΑΘΜΟΣ ΔΥΣΚΟΛΙΑΣ ΤΩΝ ΑΣΚΗΣΕΩΝ ΣΗΜΕΙΩΝΕΤΑΙ ΜΕ ΑΣΤΕΡΙΣΚΟΥΣ
* ΕΥΚΟΛΗ
** ΜΕΤΡΙΑ
*** ΔΥΣΚΟΛΗ
​**** ΠΟΛΥ ΔΥΣΚΟΛΗ