ΑΕΠΠ

Αποστολή Εξετελέσθη Πάμε Παρακάτω

  • computer_programming

Αποστολή 4: what if?

Συγγραφέας: apanagio στις 8 Μαρτίου 2010


Μια πολύ χρήσιμη εντολή είναι η ΑΝ ... ΤΟΤΕ ... ΤΕΛΟΣ_ΑΝ και οι συγγενικές ΑΛΛΙΩΣ, ΑΛΛΙΩΣ_ΑΝ, ΚΑΙ, Η, ΟΧΙ.

Το παρακάτω πρόγραμμα ζητάει δύο αριθμούς και τυπώνει το μεγαλύτερο (αν είναι ίσοι τυπώνει την τιμή τους).

ΠΡΟΓΡΑΜΜΑ μεγαλύτερος
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, max
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  ΑΝ α < β ΤΟΤΕ
    max <- β
  ΑΛΛΙΩΣ
    max <- α
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ max
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

Γράψτε τα παρακάτω προγράμματα:

  1. Ένα πρόγραμμα που ζητάει έναν αριθμό και τυπώνει την απόλυτη τιμή του
  2. Ένα πρόγραμμα που ζητάει έναν αριθμό και τυπώνει αν είναι μεταξύ 100 και 1000
  3. Ένα πρόγραμμα που ζητάει το βάρος ενός δέματος και τυπώνει πόσο θα κοστίσει η αποστολή του σύμφωνα με τον παρακάτω τιμοκατάλογο:
    Μέχρι 100gr => 0,5 €
    100 με 200gr => 1€
    200 με 1kgr => 2€
    πάνω απο 1kgr  => 4€
  4. Ένα πρόγραμμα που ζητάει 3 αριθμούς και τυπώνει τον μεγαλύτερο

Αφήστε μια απάντηση