ΑΕΠΠ

Αποστολή Εξετελέσθη Πάμε Παρακάτω

  • computer_programming

Αποστολή 8: Πολυδιάστατοι πίνακες

Συγγραφέας: apanagio στις 9 Ιουνίου 2006

multi-arrayΟι πίνακες μπορούν να έχουν παραπάνω από μία διαστάσεις.
Έτσι ένας πίνακας 2 διαστάσεων, που περιέχει πραγματικούς αριθμούς, δηλώνεται ως:
ΠΡΑΓΜΑΤΙΚΕΣ: Α[10][20]
Σε αυτό το παράδειγμα ο πίνακάς μας περιέχει 10 γραμμές και 20 στήλες.
Μπορούμε να το σκεφτόμαστε σαν ένα μονοδιάστατο πίνακα 10 στοιχείων που κάθε του στοιχείο είναι ένας πίνακας 20 στοιχείων.
Για να διαβάσουμε και να γράψουμε στα στοιχεία του πίνακα χρησιμοποιούμε τη σύνταξη: Α[ι, κ]
πχ: ΓΡΑΨΕ Α[3, 5]
Α[9, 13] <- 22.4

Το παρακάτω πρόγραμμα διαβάζει τις απουσίες 20 μαθητών για 9 μήνες και τους καταχωρεί σε έναν πίνακα 20 x 9:

ΠΡΟΓΡΑΜΜΑ απουσιες
ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ: ι, κ, α[20, 9]
ΑΡΧΗ
    ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20
        ΓΡΑΨΕ "Μαθητής ", ι
        ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 9
            ΓΡΑΨΕ "Δώσε τις απουσίες για το μήνα ", κ
            ΔΙΑΒΑΣΕ α[ι, κ]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Γράψτε ένα πρόγραμμα το οποίο:

  1. Θα διαβάζει τα ονόματα 20 μαθητών και θα τα καταχωρεί σε έναν πίνακα Ο[20]
  2. Θα διαβάζει τις απουσίες των μαθητών για τους 9 μήνες του σχολικού έτους και θα τις τοποθετεί στον πίνακα Α[20][9]
  3. Θα υπολογίζει το σύνολο των απουσιών κάθε μαθητή και θα το αποθηκεύει στον πίνακα SUM[20]
  4. Θα τυπώνει τα ονόματα των μαθητών που έχουν πάνω από 50 απουσίες
  5. Θα βρίσκει τον μαθητή που έκανε τις περισσότερες απουσίες μέσα σε ένα μήνα και θα τυπώνει το όνομά του και το μήνα που έκανε τις απουσίες.

Καλή διασκέδαση

Αφήστε μια απάντηση