ΑΕΠΠ

Αποστολή Εξετελέσθη Πάμε Παρακάτω

  • computer_programming

Αποστολή 9: Διαδικασίες και Συναρτήσεις

Συγγραφέας: apanagio στις 1 Ιουλίου 2005

Τμήματα του προγράμματός μας που τα χρειαζόμαστε πολλές φορές, μπορούμε να τα δηλώσουμε ξεχωριστά και να τα καλέσουμε στη συνέχεια όσες φορές θέλουμε. Έτσι το πρόγραμμά μας είναι καλύτερα δομημένο και πιο κατανοητό.
Τα τμήματα αυτά ονομάζονται υποπρογράμματα και είναι δύο ειδών: Διαδικασίες και Συναρτήσεις

Διαδικασίες

Οι διαδικασίες είναι υποπρογράμματα που γράφονται μετά το κυρίως πρόγραμμα. Μπορούν να κληθούν με την εντολή «ΚΑΛΕΣΕ» από οποιοδήποτε σημείο του προγράμματος. Οι παράμετροι αναφέρονται ονομαστικά κατά τη δήλωση της διαδικασίας και στη συνέχεια ο τύπος τους δηλώνεται στο τμήμα «Μεταβλητές».

ΠΡΟΓΡΑΜΜΑ ΑΠΛΗ_ΔΙΑΔΙΚΑΣΙΑ
ΑΡΧΗ
  ΚΑΛΕΣΕ χαιρετα('JAMES', 'BOND') 
  ΚΑΛΕΣΕ χαιρετα('ΜΑΡΙΑ', 'ΝΟΜΙΚΟΥ')
  ΚΑΛΕΣΕ χαιρετα('Γιάννης', 'Παπαδόπουλος')
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ χαιρετα(όνομα, επώνυμο) 
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: όνομα, επώνυμο
ΑΡΧΗ
  ΓΡΑΨΕ 'my name is ', επώνυμο, '. ', όνομα, ' ', επώνυμο
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Συναρτήσεις

Η ΓΛΩΣΣΑ επιτρέπει τη δημιουργία συναρτήσεων από το χρήστη. Το αποτέλεσμα κάθε συνάρτησης έχει πάντα τιμή κάποιου τύπου δεδομένων και δηλώνεται μετά τις παραμέτρους της συνάρτησης (ΑΚΕΡΑΙΑ, ΠΡΑΓΜΑΤΙΚΗ, ΧΑΡΑΚΤΗΡΑΣ ή ΛΟΓΙΚΗ). Οι συναρτήσεις δεν επιτρέπεται να επιστρέφουν πίνακες. Όλες οι συναρτήσεις πρέπει να περιέχουν μία εντολή του τύπου ΌνομαΣυνάρτησης <- τιμή, ώστε να επιστρέφουν κάποια τιμή στο καλών υποπρόγραμμα.

ΠΡΟΓΡΑΜΜΑ Συναρτήσεις
ΑΡΧΗ
  ΓΡΑΨΕ μήκος(2, 3) 
  ΓΡΑΨΕ μήκος(2.4, -3) 
  ΓΡΑΨΕ μήκος(1.2, 2.3) 
  ΓΡΑΨΕ μήκος(-1, 4.3) 
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ μήκος(χ, υ): ΠΡΑΓΜΑΤΙΚΗ
!Βρίσκει το μήκος του διανύσματος (χ, υ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: χ, υ
ΑΡΧΗ
  μήκος <- χ* χ + υ* υ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Ασκήσεις

  • Γράψτε μια συνάρτηση που θα δέχεται 2 πραγματικούς (α, χ) και θα υπολογίζει το (χ-α)^2
  • Γράψτε μια συνάρτηση που θα δέχεται 1 πίνακα 10 θέσεων και θα υπολογίζει τη μέση τιμή των στοιχείων του πίνακα
  • Γράψτε μια συνάρτηση που θα δέχεται 1 πίνακα 10 θέσεων, θα υπολογίζει το άθροισμα των (χ-α)^2 όπου χ είναι το κάθε στοιχείο του πίνακα και α η μέση τιμή των στοιχείων (ονομάζεται διασπορά)
  • Γράψτε μια διαδικασία που θα δέχεται 2 πίνακες 10 στοιχείων και θα τυπώνει αυτόν με τη μικρότερη διασπορά
  • Γράψτε ένα πρόγραμμα που θα ζητάει από το χρήστη 2 πίνακες και θα τυπώνει αυτόν με τη μικρότερη διασπορά. Μετά θα ρωτάει το χρήστη αν θέλει να σταματήσει και θα συνεχίζει εκτός αν ο χρήστης γράψει ‘ν’

Αφήστε μια απάντηση