Αλγόριθμος εύρεσης μεγαλύτερου αριθμού από ένα πλήθος θετικών αριθμών

Αλγόριθμος μεγαλύτερος1 !1η λύση με αυθαίρετη αρχικοποίηση ! Ο αλγόριθμος βρίσκει τον μεγαλύτερο αριθμό από ένα πλήθος θετικών αριθμών ! Το τέλος εισαγωγής των αριθμών δηλώνεται με την εισαγωγή ενός αρνητικού αριθμ. μαξ ← -1 Διάβασε χ Όσο χ > 0 επανάλαβε Αν χ > μαξ τότε μαξ ← χ …

Διάβασε περισσότερα

Εμφάνιση στοιχείων διασδιάστατου πίνακα από ένα στοιχείο Α[α1,β1] μέχρι ένα επόμενο στοιχείο Α[α2,β2]

1η Λύση ΠΡΟΓΡΑΜΜΑ ΣΑΡΩΣΗ_ΠΙΝΑΚΑ1 ΜΕΤΑΒΛΗΤΕΣ ΑΚΕΡΑΙΕΣ: Α1, Β1, Α2, Β2, Ι, Ξ, Α[3, 4] ΑΡΧΗ ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 3 ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 4 ΔΙΑΒΑΣΕ Α[Ι, Ξ] ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ ΔΙΑΒΑΣΕ Α1, Β1             !υποθέτουμε ότι το δεύτερο στοιχείο !βρίσκεται μετά το πρώτο μέσα στον πίνακα ΔΙΑΒΑΣΕ Α2, Β2

Διάβασε περισσότερα