Αλγόριθμος εύρεσης μεγαλύτερου αριθμού από ένα πλήθος θετικών αριθμών

Αλγόριθμος μεγαλύτερος1
!1η λύση με αυθαίρετη αρχικοποίηση
! Ο αλγόριθμος βρίσκει τον μεγαλύτερο αριθμό από ένα πλήθος θετικών αριθμών
! Το τέλος εισαγωγής των αριθμών δηλώνεται με την εισαγωγή ενός αρνητικού αριθμ.

μαξ ← -1
Διάβασε χ
Όσο χ > 0 επανάλαβε
Αν χ > μαξ τότε
μαξ ← χ
Τέλος_αν
Διάβασε χ
Τέλος_επανάληψης
Εμφάνισε μαξ    !υποθέτουμε ότι δόθηκαν αριθμοί αλλιώς θα εμφανίσει -1(αυθ. αρχ.)
Τέλος μεγαλύτερος1

___________________________________

Αλγόριθμος μεγαλύτερος2
!2η λύση χωρίς αυθαίρετη αρχικοποίηση. Αρχικοποίση με τον πρώτο αριθμό.

Διάβασε χ
μαξ ← χ
Όσο χ > 0 επανάλαβε
Αν χ > μαξ τότε
μαξ ← χ
Τέλος_αν
Διάβασε χ
Τέλος_επανάληψης
Εμφάνισε μαξ    !υποθέτουμε ότι δόθηκαν αριθμοί αλλιώς θα εμφανίσει
!τον πρώτο αριθμό που δόθηκε και θα είναι αρνητικός ή μηδέν.
Τέλος μεγαλύτερος2

___________________________________

Αλγόριθμος μεγαλύτερος3
!3η λύση με αρχικοποίηση μέσα στο βρόχο και μετρητή των αριθμών που δίνονται.

μ ← 0
Διάβασε χ
Όσο χ > 0 επανάλαβε
μ ← μ + 1
Αν μ = 1 τότε
μαξ ← χ
αλλιώς_αν χ > μαξ τότε
μαξ ← χ
Τέλος_αν
Διάβασε χ
Τέλος_επανάληψης
Αν μ ≠ 0 τότε
Εμφάνισε μαξ
αλλιώς
Εμφάνισε «Δεν δόθηκαν θετικοί αριθμοί»
Τέλος_αν
Τέλος μεγαλύτερος3

Αφήστε μια απάντηση